Getting CGroup swap accounting to work

I entered “sudo lxd” and the following warning message was returned:

WARN[12-13|08:03:37] CGroup memory swap accounting is disabled, swap limits will be ignored.

This is on Ubuntu 16.04 64bit

Also, I have updated /etc/default/grub as required:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash swapaccount=1"
sudo update-grub
sudo reboot

Should the WARN(ing) message still be there after doing that? The instructions at stated “One exception to this is that in order to enable swap accounting the boot argument swapaccount=1 must be set.”

Not really sure if I did anything wrong here to cause the WARN(ing) message above as well as for “swap accounting is disabled, swap limits will be ignored” Seems this shouldn’t be happening with the swapaccount=1 config set.

Thanks in advance for any advice.

Do you actually see swapaccount=1 in /proc/cmdline?

My local system works fine here with:

stgraber@castiana:~/data/code/lxc/lxd (stgraber/master)$ cat /proc/cmdline 
BOOT_IMAGE=/vmlinuz-4.13.0-16-generic.efi.signed root=ZFS=castiana/ROOT/ubuntu ro quiet splash net.ifnames=0 swapaccount=1 vt.handoff=7