Import old ZFS storage to another server

I have cloned whole rpool with zfs send ... | ssh root@secondserver zfs recv ... from one server to another.
Everything works fine, except LXD. systemctl status showed that snap/LXD cant’s start. I tried to resolve this problem, but had not succeed. So I’ve reinstalled LXD. Now LXD works, but it’s empty.
So I tried this ( method, but got:

lxd import mycontainer Error: The instance's directory "/var/snap/lxd/common/lxd/storage-pools/lxd/containers/mycontainer" appears to be empty. Please ensure that the instance's storage volume is mounted

but it’s not empty:

ls -A /var/snap/lxd/common/lxd/storage-pools/lxd/containers/mycontainer/ backup.yaml metadata.yaml metadata.yaml~ rootfs templates

It’s empty from LXD’s point of view. We have scheduled work over the next few months to replace lxd import with a lxd recover which will be much smarter about handling this and require less manual intervention on your part.

For now, your problem is that the ZFS datasets aren’t mounted in LXD’s mount namespace so it can’t se them. Run sudo nsenter --mount /run/snapd/ns/lxd.mnt bash to get a terminal inside of LXD’s mount namespace. Then use mount -t zfs pool/dataset /full/path to mount whatever is missing. lxd import should then behave.

Tried, but failed:

sudo nsenter --mount /run/snapd/ns/lxd.mnt bash
nsenter: neither filename nor target pid supplied for ns/mnt

Hmm, weird, maybe try --mount=/run/snapd/ns/lxd.mnt instead of using a space?

I will try.
Thank you.