Incus can't init


I have been reading about Incus for a bit now, and want to use it for a virtual server. I would like to use Incus to make a Debian VM, and run Incus in that VM for LXC containers. I am booting 64-bit Debian-based MX Linux with KDE, so it’s AHS advanced hardware support, which is supposedly a kernel option or configuration.
I am using the systemd boot option for MX Linux, and I was able to get the incus and incus-client installed via apt-get. It repeatedly failed or configured something wrong when installing with nala. Once it was installed, I rebooted. I first tried to run incus admin init, and it just hang’d. The system didn’t freeze, and I could open a new Yakuake shell, but there was no output. Ctrl+C interrupts it fine, but it doesn’t seem to change anything. I’ve done that a few times.
The same thing happens with systemctl start incus–it just hangs. I just checked the MX Service Manager, and saw that incus-lxcfs is the only incus daemon still running. I started incus-user and incus. The incus daemon had the attached output.

If I read that error right, there’s no incus service file? Sure enough, ls shows only four items for /etc/systemd/system/incus*:

  • incus-lxcfs.service
  • incus-startup.service
  • incus.socket
  • incus-user.socket

It’s borked somewhere, right? I kinda blame systemd, but only because I don’t know how to use it. I’ve been trying not to use it. Any help, other than recommendation to reinstall or reboot, would be much appreciated.

Much obliged,


What distribution is that on?

Per the error, you’re missing the setfattr command. On Debian/Ubuntu this comes from the attr package which is a dependency of the incus package I produce (GitHub - zabbly/incus: Incus package repository).

So this suggests you installed Incus from some other package or source which didn’t bring in the needed attr package.

1 Like

Hello, Stephane!

MX Linux

How peculiar. I installed incus via the zabbly repository, which I assumed is yours. I do have that package…

Yeah, very odd. Can you show which setfattr? Just want to make sure that the binary actually exists.

Another option could be that MXLinux runs with an odd PATH for systemd units and so incus somehow can’t locate it?

Drat. It’s blank. That does mean there’s something wacky with the path.

I don’t know what the actual standard is, or if people use it, but the systemd page of the MX Linux wiki suggests the system could keep service files in /usr/lib/systemd/system/. Sure enough, I see some there.

Maybe this is a systemd problem, and not an Incus problem? Can Incus work without systemd? I’d like for it to.

Can you show cat /var/lib/dpkg/attr.list
And also check that you don’t actually have the binary at /usr/bin/setfattr?


I’m so confused, I guess I just don’t understand MX Linux :slight_smile:

So you do have attr installed according to the distro’s package manager, you also do have the incus package which specifically depends on that thing, then where are the binaries from the attr package? :slight_smile:

Short of anything smarter to do, can you run find /usr | grep setfattr or something along those lines to locate where the thing is?

Ya know, I have no idea if this is an MX Linux thing, or not. You really hit the nail on the head, though:

So, I ran apt-get to reinstall attr, verified setfattr’s binary, ran apt-get to reinstall incus, and ran the init with --minimal, again. It still produced no output, but it did not hang! I just have another prompt, so now I suppose I have lots of configuring to do.
I have no idea what was going on. Thank you for your prompt help! I will be back with more :man_facepalming: impasses.