Incus launch new container not working

Hi All,

I migrated from lxd to incus. everything went smooth. However i can not seem to launch a new container.

any help would be appreciated.

root@esx:~# incus launch images:debian/12/cloud controller-new
Launching controller-new
Error: Failed instance creation: Failed getting remote image info: Failed getting image: The requested image couldn’t be found

strange now it works?

If you run the following, it should give you the full list of available images that are currently available, along with their hash/fingerprint.

incus image list images:

If something goes wrong, you can save the output of that command, in order to be able to diagnose later.

Also, you can run the following to get information on a specific image,

$ incus image info images:debian/12/cloud
Fingerprint: bfa74da4e61b55cc620a5d0f897d3ce95cbb30e39773777bcd0cf9159d91c0cb
Size: 122.02MiB
Architecture: x86_64
Type: container
Public: yes
    Created: 2024/02/02 00:00 UTC
    Uploaded: 2024/02/02 00:00 UTC
    Expires: never
    Last used: 0001/01/01 00:00 UTC
    architecture: amd64
    variant: cloud
    type: squashfs
    os: Debian
    release: bookworm
    description: Debian bookworm amd64 (20240202_05:24)
    serial: 20240202_05:24
    - debian/bookworm/cloud
    - debian/bookworm/cloud/amd64
    - debian/12/cloud
    - debian/12/cloud/amd64
Cached: no
Auto update: disabled
Profiles: []

I do not know the mechanics of image creation. Perhaps you tried to launch an image at the exact moment that it was being updated?

Incus has a built-in cache for the image list, it’s quite possible that your system somehow accessed bad data which was kept in cache for a few minutes, then on re-try things worked properly.