Install ISO | BdsDxe: Failed [update] [solved]

No matter which iso use always get this error.

I follow this guide.

what im doing wrong? I already try with:
ubuntu 18.04
ubuntu 20.04
Proxmox 7
Mikrotik ISO.

I figoure it out: Issue related with EFI boot, exist anyway to Force LXD to boot using Bios?

1 Like

See if this helps you:


1 Like

Thanks! this really work.

1 Like

While this thread has been solved, I’ll write in actual words how to fix the issue for those who are in a rush and don’t wish to watch a video: all you need to do is set boot.priority for the ISO-image you want to boot, like e.g. lxc config device set myvirtualmachine iso boot.priority=10 – POOF, UEFI will boot from the ISO-image by default.

1 Like

But what about pfsense? if I try with lxc config device set myvirtualmachine iso boot.priority=10 – they will boot without problem?

You asked how to get EFI to boot from the correct device and you do that with boot.priority. You still need to do the other extra steps as well, if you want to boot anything based on FreeBSD.

1 Like

You right