Install specific LXD version in Ubuntu 16.04.2

I have a question for you.

I would like to install a specific version (2.13) of LXD on Ubuntu 16.04.2LTS.
Now I have 2.15. Is it possible to downgrade or follow a tutorial regarding installation of the specific version that I need?

Thank you.

Downgrade isn’t supported, if you attempt it, LXD will refuse to start due to the database schema having changed between LXD 2.13 and LXD 2.15.

If you are asking about downgrading the packages of LXD to 2.13 and you do not mind clearing up any existing container in order to start again from scratch, then it should be possible.

You would need to uninstall/purge the current LXD packages, then install the specific version of LXD you need.
However, having a look at shows that the older LXD versions are not available anymore (currently, only LXD 2.15 is there). Therefore, you would need to find the set of LXD 2.13 packages from your /var/cache/apt/archives/ (if they are still there).

You could look into the “backports” repository if it has the 2.13 version,
However, it does not have it, it has 2.14.

There are some other, more involved, ways to try to get LXD 2.13. But why get this specific version of LXD?

Hello, thank you both for your replies.

I would like to install a specific version for LXD because I have a configuration with openstack and LXC containers and when I do the upgrade from 2.0.10 to 2.15 I cannot create instances in openstack.
In the 2.0.10 version I can create LXD ubuntu instances but this LXD version does not support USB passthrough, which is indispensable for my configuration environment. So, I am stuck somewhere in the middle.

So, you want to try specifically LXD 2.13 just because it is one of the in-between versions for 2.0.x and 2.15?

In your case, I would try to get support on why LXD 2.15 may have an issue with creating instances in OpenStack. Whether the issue is related to the upgrade from LXD 2.0.x or is something else.

Hi simos, thank you for the reply.

We have already done it here:

Has anyone faced the same or similar issue?