Launching VM with manually imported image

I’m working with Puppet to automaticaly deploy resources and was using OVH’s Puppet module.

However their module does not yet support VMs so I attempted to implement it by executing the installation through the command line as shown here using the official image repository.

I ran the following commands:

$ lxc image import lxd.tar.xz disk.qcow2 --alias ubuntuvm-test
$ lxc image list
|     ALIAS     | FINGERPRINT  | PUBLIC |                  DESCRIPTION                  | ARCHITECTURE |      TYPE       |   SIZE   |         UPLOAD DATE          |
| ubuntuvm-test | e7904075aac3 | no     | Ubuntu focal amd64 (cloud) (20201009_07:42)   | x86_64       | VIRTUAL-MACHINE | 258.25MB | Oct 9, 2020 at 3:10pm (UTC)  |

$ lxc launch ubuntuvm-test test -p vm
Creating test
Starting test                              
Error: Failed to run: /snap/lxd/current/bin/lxd forklimits limit=memlock:unlimited:unlimited -- /snap/lxd/16922/bin/qemu-system-x86_64 -S -name test -uuid 1d80fd9e-bfb1-4676-af06-59530c84f2cb -daemonize -cpu host -nographic -serial chardev:console -nodefaults -no-reboot -no-user-config -sandbox on,obsolete=deny,elevateprivileges=allow,spawn=deny,resourcecontrol=deny -readconfig /var/snap/lxd/common/lxd/logs/test/qemu.conf -pidfile /var/snap/lxd/common/lxd/logs/test/ -D /var/snap/lxd/common/lxd/logs/test/qemu.log -chroot /var/snap/lxd/common/lxd/virtual-machines/test -smbios type=2,manufacturer=Canonical Ltd.,product=LXD -runas lxd: : exit status 1
Try `lxc info --show-log local:test` for more info

My vm profile is as follows and works with regular VM instance launch with the --vm option:

config: {}
description: ""
    source: cloud-init:config
    type: disk
    name: eth0
    nictype: bridged
    parent: br0
    type: nic
    path: /
    pool: default
    type: disk
name: vm
- /1.0/instances/test

Any help is grreatly appreciated.

What’s the qemu error?

I tried creating the VM again but it was successful. I was unable to recreate the error, must’ve been a one time thing, I’ll report the log if it pops up again.

I eventually found out what the problem was, I was running a VirtualBox VM that acted as a Puppet agent for testing purposes. Since LXD VMs uses qemu it seems there was a control issue with VT-x as expected. I only needed to turn off the VBox VM.