Limit of 90 containers


problem: Im able to make only first ~90 approximately containers running. Adding/starting more results in containers with status STOPPED.

Im trying to run multiple LXC containers inside ESXi vm.
And Im not able to run more then ~90 instances per VM. Some times it starts 96 or 87.
Ive spent some time googling, yet Ive failed to identify the reason.

Ive tried to increase/decrease resources like ram and cpu count.
Also Ive tried to run it on single VM and in cluster. Same result.
In cluster based in 4 VMs I get 367 containers running, addition results in appearance of new stopped containers.
Ive experimented with OVN with same result.
Im using ubuntu 20.04 by the way. Fresh and updated.

What am I missing? Plz give me some clues…

You didn’t actually say what happens when you try to get more containers running.

oh, yes, Ive added problem statement.

So the problem is that containers appears as STOPPED and I want them to be RUNNING.

If lxc start doesn’t fail, then init was spawned in the container, if the container then goes to STOPPED, it means init died in there.

Look at lxc console --show-log NAME which may tell you why.

Normally my guess would be that you exceeded inotify watches or another similar system resource.

Did you follow Production setup - LXD documentation ?

The sysctls in there tend to be needed unless you’re running just a few containers as systemd will otherwise run out of global resources.

1 Like