Lxc-attach error: Failed to open terminal multiplexer device


I’ve just upgraded from debian buster to bullseye on an arm64 platform.
For various reasons unrelated to this issue, I run debian with sysv init instead of the default systemd.
On this platform, I have an unprivileged container, also running a sysv init bullseye debian, which worked fine before the upgrade.
After the upgrade of the host to bullseye, the lxc-attach command starts to display this error:

terminal.c: lxc_terminal_create_native: 924 Permission denied - Failed to open terminal multiplexer device

Yet, I am connected to the container as expected.
I wonder if the above error is the symptom of something I have to take care of, or if I can simply ignore it.

Could someone explain me what it means and what I should do to get rid of it ?


Any ideas on this @brauner thanks.

You can ignore this error safely. I probaly can change the error message to a warning message.

1 Like

Good !
Thanks to both of you :slight_smile: