Lxc-autostart stopped working on boot on Centos 7


I have been running lxc containers for a while and lxc-autostart always worked with no issues. I have made no changes but now lxc no longer starts the containers on boot. If I manually run lxc-autostart after boot it works fine. I checked systemd and lxc is enabled. I have no idea why this is not working. Any tips on how best to troubleshoot it?

I am running Centos 7. I have a autostart delay of 18 seconds which should be more than enough…

When I run lxc-autostart -L no containers show, but when I run lxc-ls -f the containers show with a “1” in the AUTOSTART column

I figured out the issue was a file present in /usr/local/var/lock/lxc, once i removed that it started working again.

1 Like