Lxc publish is not working

I have a problem

I was trying to “lxc publish” and I forced abort (crtl+c 2x) because it stuck, but when I try again “lxc publish” now it doesn’t work like blank.

When I Ctrl+C, there are output like this :

This Operation can't be cancelled (interrupt two more times to force)
Error: User signaled us three times, exiting. The remote operation will keep running

And when I trying again “lxc publish name_container --alias name_container_img” nothing comes out like blank.

Note that you didn’t actually cancel it, so looking at lxc operation list, you’ll likely still see it happening in the background.

You may want to look at ps fauxww to see if something actually got stuck and kill that which should unblock the rest.

Thanks for reply.

How to stop its operation?

I’ve tried “lxc operation delete” but still got error :

Error: This Operation can’t be cancelled

Do you see an operation running still as @stgraber asked?

And do you see any publish related processes running in ps fauxww?

What are the grep parameters?

I’ve tried “ps fauxww” and the results are so overwhelming that it makes me dizzy.

Here “lxc operation show d6f4896b-043f-487b-8c54-43dfeb7b970d” :

id: d6f4896b-043f-487b-8c54-43dfeb7b970d
class: task
description: Downloading image
created_at: 2022-07-06T15:10:15.568869082+07:00
updated_at: 2022-07-06T16:16:00.160896822+07:00
status: Running
status_code: 103
resources: {}
  create_image_from_container_pack_progress: 'Image pack: 202.99GB (51.46MB/s)'
    processed: "202988938240"
    speed: "51460505"
    stage: create_image_from_container_pack
may_cancel: false
err: ""
location: none

Given your other thread is talking about ZFS, I am going to go out on a limb and suggest that perhaps you have filled up your ZFS pool or root disk and the image pack is hanging because when ZFS reaches almost full, rather than failing cleanly, it slows down to a crawl effectively blocking writes.

Take a look for running tar or gzip processes.