Lxc snap wedged. Unable to refresh/install/enable

Just tried to use lxc and found the snap was “broken”. I tried to disable/enable, but once disabled I can’t re-enable it. Refresh and enable are now not possible so I can’t actually get it working again.

installed:                               (11381)   0B disabled,broken
alan@KinkPad-K450:~$ snap enable lxd
error: cannot perform the following tasks:
- Setup snap "lxd" (11381) security profiles (cannot find installed snap "lxd" at revision 11381: missing file /snap/lxd/11381/meta/snap.yaml)
alan@KinkPad-K450:~$ snap refresh lxd
error: cannot refresh "lxd": refreshing disabled snap "lxd" not supported

I also tried manually grabbing the snap to install it.

alan@KinkPad-K450:~$ snap download lxd
Fetching snap "lxd"
Fetching assertions for "lxd"
Install the snap with:
   snap ack lxd_11381.assert
   snap install lxd_11381.snap
alan@KinkPad-K450:~$  snap ack lxd_11381.assert
alan@KinkPad-K450:~$  snap install lxd_11381.snap
error: cannot install snap file: cannot update disabled snap "lxd"

I am basically trying to avoid doing a snap remove because I don’t want to lose my containers. Is there some way to un-wedge it?

Sounds like there may be something wrong with your /snap/lxd/11381 mount?

Manually re-mounting this, potentially by just bind-mounting a newer or older rev on top of it should be enough to motivate it to start again.

Sounds like a snapd bug though, so maybe better discussed on the snapcraft forum?

1 Like