Lxc-start fails. Logfile shows net quota problem

Hi All,
I’m following a basic web instruction on using lxc and I created an unprivileged container named c1. When I try to start c1, it fails. The specific line in the logfile is:

lxc-start c1 20201025225547.195 ERROR network - network.c:lxc_create_network_unpriv_exec:2657 - lxc-user-nic failed to configure requested network: cmd/lxc_user_nic.c: 1208: main: Quota reached

my ~/.config/lxc/default.conf file is:

lxc.idmap = u 0 100000 65536
lxc.idmap = g 0 100000 65536
lxc.net.0.type = veth
lxc.net.0.link = lxcbr0

ifconfig shows the ‘lxcbr0’ network connection is up:

lxcbr0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
inet netmask broadcast
ether 00:16:3e:00:00:00 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

My system is Linux Mint 20.0 running linux kernel 5.4.0-52-generic. I’m not sure what additional info to add. The log message doesn’t leave much to go on. Neither syslog or ‘journalct l |grep lxc’ showed any clues. I’ve looked at the forum posts that were similar but none were about the network or ‘quota’ errors.
Thanks for any info you could share.
Best regards,
Bob G.

Your /etc/lxc/lxc-usernet file isn’t allowing your user to attach to lxcbr0

Thank you for your response.

I got this from a tutorial on setting up an lxc container. Is it wrong?

cat /etc/lxc/lxc-usernet


   bob veth lxcbr0 10

I’ve also tried 2 instead of 10 and tried removing the indentation from the entry.

EDIT: OOPS!. My lxc-usernet file got reverted to above due to a restore when I thought I had messed up and wanted to start over. After changing the 10 to 2, it worked. Thanks so much for getting me on track.

I still got an error although my container is running
:~$ cat c1.log

lxc-start c1 20201027162807.439 ERROR conf - conf.c:lxc_setup_boot_id:3249 - Permission denied - Failed to mount /dev/.lxc-boot-id to /proc/sys/kernel/random/boot_id

Best regards,
Bob G.

Yeah, that’s not a real error, I think we’ve actually silenced it in recent changes.