LXD 4.0: Cannot use `--vm` - errors

Hello, all.

Trying to start testing LXD Virtual Machines / QEMU, but getting some errors.

Namely, whenever I launch a container with lxc launch --vm ubuntu:18.04 bionicvm I get the following output and failure:

$ lxc launch --vm ubuntu:18.04 bionicvm
Creating the instance
Instance name is: bionicvm
Starting container
Error: Failed to run: modprobe vhost_vsock: modprobe: ERROR: could not insert 'vhost_vsock': Device or resource busy
Try `lxc info --show-log local:bionicvm` for more info

$ lxc info --show-log local:bionicvm
Name: sunny-seasnail
Location: none
Remote: unix://
Architecture: x86_64
Created: 2020/04/07 00:57 UTC
Status: Stopped
Type: virtual-machine
Profiles: default
Error: open /var/snap/lxd/common/lxd/logs/bionicvm/qemu.log: no such file or directory

Little bit stuck on how to proceed to utilize LXD 4.0.1 and its vm functionality.

This is running on my Ubuntu 18.04 laptop, with a GUI. It has VMware installed because I need that for some work VMs, but I’d still like to use LXD’s VM functionality. Any ideas on how to get started with that?

21:03:33 	<stgraber>	usually means that you have another vsock stack loaded
21:03:35 	<stgraber>	like vmware's
21:03:46 	<stgraber>	"lsmod | grep vsock" is usually a good starting point

Copy/pasting the answer I gave you on IRC.

1 Like

Ah, looks like you got that far.

Well, unless there’s a way to disable VMWare’s own vsock without breaking it, I’m afraid you’re likely stuck.

LXD needs vsock for its VMs so it’s not a bit we can really run without.

Hmm, that’s going to be… a possible issue.

I’m not opposed to removing VMware for now, so long as VMware lets me download it again heh…

Only the kernel module should be conflicting, so if you can locate and temporarily rrmod the VMWare vsock implementation, you should be fine.

I meant rmmod.

For a more permanent solution, if VMWare doesn’t mind this, you may be able to put a blacklist in place in /etc/modprobe.d to prevent it from loading the conflicting module.

VMware Workstation was used specifically for some specific cases. What I’m going to do is work on slowly migrating my VMware VMs directly over to my VMware ESXi cluster on a dedicated network segment. That means I can remove my VMware Workstation stuff heh. Failing that, I’ll figure out something else going forward, but for now since my VMware Workstation key expires in 30 days anyways, I’ll just remove it for now (since it just takes up space).

I removed the VMware Workstation right now.

Trying to figure how to configure the VM size to have a specific disk size, is that in cloud-init anywhere or otherwise configurable via the profile?