LXD - Failed to start the daemon

Hi, I am following this Install Charmed Ceph | Ubuntu documentation for deploying a ceph cluster and having some issues to deploy LXD.

I am having an lxd version : 4.19 which is installing on Ubuntu 20.04.

  1. lxd --verbose --debug output:

EROR[10-29|18:46:19] Failed to start the daemon err=“LXD is already running”
INFO[10-29|18:46:19] Starting shutdown sequence signal=interrupt
WARN[10-29|18:46:19] Instance type not operational type=virtual-machine driver=qemu err=“KVM support is missing”
INFO[10-29|18:46:19] Not unmounting temporary filesystems (instances are still running)
INFO[10-29|18:46:19] Daemon stopped
Error: LXD is already running

  1. systemctl -a | grep snap.*lxd output:

I tried running sudo systemctl reload snap.daemon.lxd to restart LXD demon. but that does’nt help to restart lxd instances.

Any help for this?
Please let me how to resolve this problem.
Thank you.

Any possible solutions on this issue??

What happens when you run lxc info?
And what does journal -u snap.lxd.daemon -n 50 show you?

Can you show output of sudo ps aux | grep lxd, I wonder if there is a stuck LXD process, possibly related to

Here is the result of lxc info

Output of sudo ps aux | grep lxd : result

Thank you @stgraber and @tomp for the response. Much appreciated :blush:

Can you kill process 2015948?

Yupp, I killed the process 2015948

Still getting the error?

I dont know if this is normal or not, but you seem to have 2 LXD snap revision mounts.

Yes, still have the same error.

Sir, I don’t know what i missed…I am a complete beginner… how do i remove one of the LXD snap revision mount. dose that work for me?

I’m not sure about snap packages, @stgraber do those mounts look problematic to you?

I’m confused here, the output above for lxc info is all normal looking.
It’s normal for there to be two mounts, snapd keeps the previous revision around.

Unless I missed something, LXD is perfectly functional here, since it’s running, there’s no point in trying to start the daemon a second time by running lxd --verbose --debug.

It looks to me like this system is working perfectly normally and that lxc info shows a healthy LXD and I’d expect lxc list to similarly show a list of instances or none if none have been created so far.