LXD Fails to initialize when going through Canonical MAAS bootstrap

I created a similar topic on the Canonical forums, but what suggested that it maybe an LXD issue, and that I should come here instead.

This is my post from the other forum:

"I am looking to setup Maas on a virtual machine, this vm, is my region controller. I have followed the bootstrap-maas setup guide to a tee, even the ones that come before it.

I hit a bump when Activity 4 came along. After many retries, restarts, resets, wipes, refreshes, I could not get it to work. I also tried following the ‘how to setup lxd’ doc, that also didn’t work. No matter what combination of yes/no questions I tried when first setting it up.

If I said ‘Yes’ to connect to a maas server, the error was “Could not find hostname” I tried many different hostnames to see

Anything regarding the bridge, using an existing one, resulted in an error about DHCP and DNS exiting prematurely, and giving a different IP in the error message each time.

I am able to access the Web UI, but after clicking around I couldn’t find/do anything that may help."

[This](https://maas.io/docs/bootstrap-maas) is what I have been following to set things up. To configure, I am using MobaXTerm to SSH into my region controller. I have scoured forums alike and to no avail have found one that matches my issues. Thanks!

Sorry to bounce you back and forth, but Canonical has moved LXD away from Linux Containers a week or so ago, as a result, we are no longer able to provide support here, especially when it relates to Canonical technologies…



Please could you tell me where you were referred back to this forum?