LXD Mosaic icon not showing


Why is my LXD Mosaic Icon not showing when using nginx domain ?

When I access https://localhost:444 the icon is showing.

I’ve searched on google but couldn’t find a solution.

Please help, thanks.

Any ideas @turtle0x1 ?

I dont quite follow the setup, are you proxying LXDMosaic with Nginx?

Yes, I’m proxying LXDMosaic with Nginx

Why? You’ll probably run into more problems with the sockets.

I just wanted to try to create a virtual host on nginx.

I’ve never done it and dont recommend it but I can try to replicate later it if you share what you have so far :smile:

Ok, thanks for your reply :smile:

One more thing, why is my console in LxdMosaic not working or remain blank ?

I try to follow this step Console is broken on lxd > 5.0 node <= 8 · Issue #491 · turtle0x1/LxdMosaic · GitHub but still not working at all.

Not sure, can you open an issue with more details about your install (SNAP vs script ETC)

Like this :

LXDMosaic: Shell closed, if this is un-expected it could be:

  • A network error
  • The instance was turned off
  • LXDMosaic is missbehaving
  • You’re trying to use a shell not installed (I.E bash instead of ash)

Whats the image of the container your trying to get a console for?

Was LXDMosaic installed via SNAP or with the script?

I’ve tried on Centos 7, Debian Buster and Ubuntu 20.04.

LXDMosaic via SNAP

What does snap list lxdmosaic show? The edge channel has more fixes than candidate (the console not working was a known bug in candidate)

lxdmosaic 0+git.b2a8d16 193 latest/candidate turtle0x1 -

Refresh to edge, likely to fix your issues snap refresh lxdmosaic --edge

Been meaning todo a release but keep finding new bugs / ideas.

Now the problem is like this:

LXDMosaic: Node server cant be reached.
Please report this to your admin.

Is this in the Nginx proxied setup or on the default port?

On default port