$ lxd-to-incus -bash: lxd-to-incus: command not found

Hi, I’ve installed Incus on Fedora 38 Server following the migration instructions. I’ve checked Incus info and lxd info run ok but when I run “lxd-to-incus” I get “command not found”

I’m running lxd 5.20-51a2393 Snap

Not sure what to do next?

@ganto ^

In the mean time, I built a static version of the current lxd-to-incus that you can download from https://dl.stgraber.org/lxd-to-incus

2 Likes

Thank you Stéphane - The migration worked fine.

Note for others:-
I put the static file I downloaded in /usr/bin/lxd-to-incus then chmod +x
I could then carry out the rest of the instructions from
https://linuxcontainers.org/incus/docs/main/howto/server_migrate_lxd/

Migration worked here as well, on Fedora 39. The standalone version deserves at least a mention in the official incus docs.

Note that if your /var/lib/lxd is a custom mount point, the migration tool actually addresses that and attempts to remount it. However since my filesystem layout is a bit of complex, after making changes to fstab I still needed to manually reboot the system once before incus can create new instances.

COPR bug is here: lxc-to-incus "TestConvertNetworkConfig" fails · Issue #23 · ganto/copr-lxc4 · GitHub

1 Like