So, I have successfully created many LXD VM’s on Ubuntu server with no issues. Now I am attempting to create a LXD VM on a QNAP NAS. QNAP has QEMU and LXD installed and I can create LXD containers from the command line using all current switches. The exception is trying to create a LXD VM. The qemu-img program is on the path, but I still get an error. Any ideas?

As an additional bit, on my Ubuntu Server I can see support for QEMU.

However, I am not seeing information on the QNAP LXD regarding the QEMU.

Are there any AppArmor denials in the system log?

No Thomas. If you will notice from my second screenshot of LXDWare LXD Dashboard (VMSFog) you will see that it calls out the driver version and nothing is listed for QEMU. The Ubuntu serve Mondo lists both driver versions for LXC and QEMU. VMSFog, the QNAP NAS has both LXD and QEMU. I have no problems creating QEMU VMs and also LXD containers. The issue arises when I try to create a LXD VM on the QNAP NAS and the error is it failed to run qemu-img info. That’s interesting since the qemu-img command is available at the command prompt. So, its a bit baffling as to why the lxc launch command is failing. Oh, and there is no apparmour on this node as indicated by the fact that aa-status does not find the command.

I’m not sure I’m afraid, not being familiar with QNAP environment.

The issue is that something is preventing qemu-img from being run.
Perhaps they are starting LXD with a different environment than what you’re seeing?
Or some other security layer is preventing it from starting (that is why I was thinking perhaps AppArmor).

What does QNAP say about it?

Its quite a strange version of LXD to be used as well, LXD 4.14 was one of the monthly feature releases, which are only supported for 1 month, until the next feature release. It would be more appropriate for QNAP to use one of our LTS releases, such as LXD 4.0.x LTS or LXD 5.0.x LTS.

It appears that QNAP has their head in the sand a bit. QNAP Taiwan support is slow to acknowledge any features of LXD beyond what their proprietary Container Station app offers. I am a CLI person and their general demeanor is that the CLI is unsupported. QNAP QTS is an embedded Linux that really limits end user customization to some degree. So, being an avid LXD guy, I took it upon myself to figure out what might be missing. Yes, on Ubuntu server I run LXD 5.1 and have had no issues at all with LXD VMs. This is a problem that I was hoping to solve and to feature the solution on my Youtube channel which is devoted to hosting infrastructure.

It could also be the version of qemu is too old, do you know what version of qemu-img is being used?

That is possible. Do you know how I can determine that version?

qemu-img --version should do.