LXD Websites with Iframe wil not connect?


#41

It looks fine.

Have a look though at
https://www.sslshopper.com/ssl-checker.html#hostname=lpc1.streamingworld.us:3000
This is for the service at port 3000. It does not have certificates yet. You can get either HAProxy to do the TLS Termination, or put the certificates in the container instead.


#42

Interesting observation. I will look at it. I thought I created a cert for it?

Thanks for taking time to help me with this. I appreciate it.

Ray


#43

With Express and nodejs, you will to put the certificates in the source code of the app.
I gave a link about that earlier. That’s the option to get the container to perform the TLS work.

I would suggest though to put HAProxy to perform the TLS Termination. Just like you do with the web servers.
Use the http mode instead of tcp because nodejs is http.
Also, to have Express retain the real source/client IP address, see https://stackoverflow.com/questions/10849687/express-js-how-to-get-remote-client-address


#44

This has been a very frustrating journey for me, and still no luck. So, I’ve decided to take a step or two backwards. I am trying to get this to work only as HTTP. It is actually a lot further along. At least I am
seeing a lot of activity in the console. The problem I am having now is this:

Access to XMLHttpRequest at 'http://d1zb53zr75mvvv.cloudfront.net/stream/157afb01d494b25380960d6ef382e9b6f01cde46aa832f72200c567a557c0573P720p60fps16x9.m3u8' from origin 'http://lpc1.streamingworld.us:3000' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource.

Any idea how to fix this?

Ray


#45

Hi!

Have a look at this,

With Expressjs, you can enable CORS according to https://expressjs.com/en/resources/middleware/cors.html