Macvlan and port in ubuntu 18.04

I have an lxd instance with a macvlan ip, the default ssh can be checked:

telnet localhost 22
Connected to localhost.
Escape character is ‘^]’.
SSH-2.0-OpenSSH_7.6p1 Ubuntu-4ubuntu0.2

but do it from another pc:
telnet 22
got : connection refused

ufw in the instance as well as the host machine all ‘inactive’, any idea why? the lxd instance info as follow:

lxc info bom
Name: bom
Remote: unix://
Architecture: i686
Created: 2019/02/26 13:13 UTC
Status: Running
Type: persistent
Profiles: default
Pid: 11917
eth0: inet vethLNXU25
eth0: inet6 fd42:87c1:7a4b:98db:216:3eff:feef:bf9c vethLNXU25
eth0: inet6 fe80::216:3eff:feef:bf9c vethLNXU25
eth1: inet
eth1: inet6 fe80::216:3eff:feb5:8044
lo: inet
lo: inet6 ::1
Processes: 43
CPU usage:
CPU usage (in seconds): 12
Memory usage:
Memory (current): 71.93MB
Memory (peak): 72.59MB
Network usage:
Bytes received: 7.75kB
Bytes sent: 7.75kB
Packets received: 105
Packets sent: 105
Bytes received: 12.37kB
Bytes sent: 9.75kB
Packets received: 129
Packets sent: 110
Bytes received: 38.82kB
Bytes sent: 936B
Packets received: 412
Packets sent: 12

turned out, ufw inactive , all ports seem closed, have to do following:
sudo ufw enable
sudo ufw allow ssh

this fix the issue