Manually choosing xtables or nftables - issues with openvz

I have recently brought a vps, and its running openvz of some version and said it supported docker.

I have tried to get lxd working and im struggling with the network side as it doesnt seem to support the inet type that lxd is using in the rule

so lxd tries to put in

table inet lxd {

        chain pstrt.lxdbr0 {
                type nat hook postrouting priority srcnat; policy accept;
                ip saddr ip daddr != masquerade

if i change the inet for ip it goes in ok

I believe this is a host kernel issue so not fixable. If I disable the part that adds rules etc then it looks like I can get things working, but thats annoying and losing a lot of the benefits of lxd

I would therefore like to select the xtables interface to use, unfortunately this is a ubuntu 22.04 vps so lxd is a snap, so not easy to change things.

Ive had a quick look but cant see any obvious way for a configuration way to force the xtables use. (have i missed it)

does anyone have a solution?



LXD will use xtables if any xtables rule exists at the time it’s started.
So just adding a pointless xtables rule should do the trick.