Network created but LXD init can't find it

Hi there.
I am quite new to lxc/lxd and humbly request some assistance.
I created a network with:
$ lxc network create mybr0 ipv4.address= ipv6.address=auto ipv4.nat=true
Then I attached it to my custom profile:
$ lxc network attach-profile mybr0 myprofile eth0
When I run LXD init I get the following response:
fatal: []: FAILED! => {“changed”: true, “cmd”: “/home/edwin/lxc/tmp/”, “delta”: “0:00:05.803811”, “end”: “2022-01-20 13:06:23.996271”, “msg”: "n
on-zero return code", “rc”: 1, “start”: “2022-01-20 13:06:18.192460”, “stderr”: “Error: Failed to update network ‘mybr0’: Network not found”, “stderr_lines”: ["Error: Failed to up
date network ‘mybr0’: Network not found"], “stdout”: “”, “stdout_lines”: []}
When I do lxc network list, I see it in the list as a bridge network.
Am I doing something wrong or missing the concept? Your assistance will be greatly appreciated.
Thanx in advance.

Hi Edwin,
Have you ever checked that documentation page?


1 Like

So you’re running lxd init after you’ve already created some stuff by hand?
Then why run lxd init at all?

Also, what does that thing do?

If you’re dealing with a cluster, the lxc network create you’ve done will only setup a local entry, it may not commit the whole thing. What’s the output of lxc network list?

1 Like

Hi there cemzafer. Thanx for the link. Heheh being a noob makes one do all kinds of silly stuff. After reading through the docs you pointed out I think I have a better understanding of how to use lxd/lxc.

You are welcome Edwin, I’m glad it’s resolved.

1 Like

@stgraber,Thank you for tour quick response. I got it to work on a set of five rpi 4’s, following your tutorial on youtube. Funny, when setting up a second set of pi’s, identically configured I get “Error: Failed to join cluster: Failed to update cluster trust: Existing server certificate with different name “rpi52” already in trust store”. I tried 3 times and every time same result. I found you could delete trust certs and reload daemon, but even that fails.
Thanx in advance