New container doesn't start

Hi,
I installed fresh dedicated server with Debian 11.
I installed probably latest LXD from snapd.
I’ve created new container and unfirtunatelly it doesn’t want to start fully. It looks like he is hanging on dnsmasq process:

ps ax on mother server:
1117 ? Ss 0:00 /bin/sh /snap/lxd/22358/commands/daemon.start
1273 ? Sl 0:02 _ lxd --logfile /var/snap/lxd/common/lxd/logs/lxd.log --group lxd
1372 ? Ss 0:00 _ dnsmasq --keep-in-foreground --strict-order --bind-interfaces --except-interface=lo --pid-file= --no-ping --interface=lxd

and container still doesn’t have IP and the only processes in it are:
[root@fh1 ~]# ps ax
PID TTY STAT TIME COMMAND
1 ? Ss 0:00 /sbin/init
62 pts/1 Ss 0:00 bash
71 pts/1 R+ 0:00 ps ax
[root@fh1 ~]#

Could you help with this?

What image are you using for that container?

It looks a lot like you’re running an image that requires cgroup1 on a system which only provides cgroup2 (Debian 11).

In container I’ve installed Centos 7. Supposly you’re going in right direction because in dmesg I have error:

[...]
[   17.079311] IPv6: ADDRCONF(NETDEV_CHANGE): lxdbr0: link becomes ready
[   17.239098] Not activating Mandatory Access Control as /sbin/tomoyo-init does not exist.
[   17.567637] cgroup2: Unknown parameter 'mode'
root@ds5~#

I’ve found your answer for that in other topic:

Yeah, you need to update your grub config to pass systemd.unified_cgroup_hierarchy=false to the kernel, then run update-grub and reboot.

So I’ve applied it on my server and it works! :slight_smile:

I’ll just add that option I’ve added to /etc/default/grub:
GRUB_CMDLINE_LINUX=“consoleblank=0 systemd.show_status=true systemd.unified_cgroup_hierarchy=false”

So thank you and respect to all maintainers of that great LXD technology!