Ovs & vlan tag with lxd

I am wondering if 4.2 new vlan is solving what I am tring to do (I am on 4.0).

When using ovs as bridge I cant use lxc config with vlan tag it doesn’t work…

Obviously I can add the vlan tag manually with some ovs-vsctl command but I would like to find a way to automatise that when the container starts…


Can you give an example of what you’re trying to do that doesn’t work?

Also 4.2 is not a supported release of LXD, you could maybe look at switching to the latest 5.0 LTS release.

for example I am trying to use :

lxc config device add fw out nic nictype=bridged parent=vswitch vlan=111 host_name=out
Error: Invalid devices: Device validation failed for "out": Invalid device option "vlan"

doing without vlan is working fine

lxc config device add fw out nic nictype=bridged parent=vswitch host_name=out
Device out added to fw

So, I was wondering if 4.2/5.0 are adding this capability ? Or is there another way to add a vlan tag ?
I am using openvswitch, I know how to add a tag vlan from ovs but I would like this to be automatic when the container starts instead of doing a command by hand which breaks all the automation

Many thanks

Yes vlan is supported in LXD 5.0

very nice that’s what I thought :slight_smile:
I flagged out the version 4.0.9 on Alpine Linux package as 5.0 is LTS, will wait for the package maintainer to update