PiMox7 - RPi4 - arm64 CT Basic Configuration


It could save my life if I get hold of :


The reason is that the new rootfs.tar.xz all give this error in proxmox:

Formatting ‘/var/lib/vz/images/101/vm-101-disk-0.raw’, fmt=raw size=4294967296 preallocation=off
Creating filesystem with 1048576 4k blocks and 262144 inodes
Filesystem UUID: 98b46793-4bee-4e7b-a8b2-72acff8af508
Superblock backups stored on blocks:
32768, 98304, 163840, 229376, 294912, 819200, 884736
extracting archive ‘/var/lib/vz/template/cache/rootfs.tar.xz’
Total bytes read: 343080960 (328MiB, 27MiB/s)
Detected container architecture: arm64
unable to open file ‘/etc/network/interfaces.tmp.94336’ - No such file or directory
TASK ERROR: unable to create CT 101 - error in setup task PVE::LXC::Setup::post_create_hook




Does anybody have this archive please?

It seems that rootfs.tar.xz is operational…
Best wishes,

I am experiencing the same issue. I’ve tried alpine and rocky images and these are fine. Just debian seems to be the problem.

The cloud version seems to work

Hi Radu,

I think that I got it to work with this one : Bullseye https://uk.lxd.images.canonical.com/images/debian/buster/arm64/default/20220503_06:11/rootfs.tar.xz



Hi Jimmy,

Unfortunately that image is no longer available on the server.

Hopefully this issue will be picked up and resolved soon.


Dig here : https://uk.lxd.images.canonical.com/images/debian/bullseye/

I’ve got the same problem with all the actual rootfs.tar.xz (23, 24 and 25 of july)
Does someone have an good image ?

Thanks in advance,

Hello Fabrice.

Please dig here https://uk.lxd.images.canonical.com/images/debian/bullseye/ and test the versions.


I know it’s an old thread, but it was never solved and I had the same issue. Found this page and wanted to help anyone else who finds it.

I’ve just managed to get Debian 12 Bullseye working with the latest Cloud image on PiMox 7:

When configuring the CT, leave IP = Static. Do not enter any IP address.

Boot the CT, enter the CTs console.

Install Nano (who doesn’t need nano anyway! You can use vi/vim if you’re fancy, I’m not)
apt install nano

Edit the network configuration file
nano /etc/systemd/network/eth0.network





Restart Systemd Networkd
systemctl restart systemd-networkd

Check the static IP is set (you’ll probably also see the DHCP IP is still there)
ip -c a

reboot now

You’ve now got the static IP set up (if you don’t reboot, it’ll still keep the DHCP assigned IP in addition to the static)

Sorry to resurrect an old thread, but how did you install nano if you have no network. Your method works to get the VM booting, but I do not have network access in the LXC.

Sorry, the notification email was in my junk folder!

for me, the container did have network access, it had the original IP it was given via DHCP.

Check the static IP is set (you’ll probably also see the DHCP IP is still there)