Port 8443 not available (used and blocked by OVH/Cisco)

Is there a way to add a remote host by using a different port than 8443?
I have 1 dedicated server (local server) and 1 public cloud instance that I want to use as a backup, both at OVH.
I opened all ports and tested if available with nmap. Only 8443 is not available.
I know that port 8443 is used by Cisco WaaS Central Manager standard SSL administration port and this is the kind on material OVH is using.
I changed port to 8444 and I get something like that with lxc info ->
core.https_address: ‘[::]:8444’


  • 54.xx.yy.zz:8444
  • ‘[2607:5300:203:2f4b::]:8444’
  • 10.xx.yy.1:8444

    driver: lxc
    driver_version: 3.0.1
    kernel: Linux
    kernel_architecture: x86_64
    kernel_version: 4.15.0-29-generic
    server: lxd
    server_pid: 3135
    server_version: 3.0.1
    storage: btrfs
    storage_version: 4.15.1
    server_clustered: false
    server_name: host.xyz.net
    So I tried to add a remote host and I get this error message:

Generating a client certificate. This may take a minute…
Error: Get https://54.xx.yy.zz:8443: Unable to connect to: 54.xx.yy.zz.207:8443

Curl still try to get connected on port 8443.

Is there a way to use a different port.

Thanks !


Did you try to add the remote as:

lxc remote add myremote https://54.xx.yy.zz:8444

I just tried lxc remote add myremote https://54.xx.yy.zz:8444 and the command doesn’t terminate.

But while I was waiting I tried to nmap -A 54.xx.yy.zz -p 8443 and the port 8443 was NOT blocked.

So my theory is not good.

Any other idea ? I’m working on that stupid thing since several hours already.


You need to troubleshoot this properly.
See https://stgraber.org/2016/04/18/lxd-api-direct-interaction/ and how to use curl to test all steps.

Thanks Simos,

I’ve rebuilt both servers from scratch and init lxd with zfs on loop so I can add a working remote on port 8443. If I try to reverse the process between servers I have the same problem.

I’ll troubleshoot this tomorrow following the link you shared and see what is going on with this public cloud instance.

Thanks again!

1 Like

I reinstalled Ubuntu 18.04 (basic install) on both the dedicated and the cloud instance TWICE trying to see why I can’t get remote installation working from the decicated (first try) while I can do it from the cloud instance (second try).
So too much loss of time on that. I’ll use it like that.

1 Like