Problem With OVN and Network Zones

Hello LXD Fam!

I have been having this issue with my Network Zones! It seems like when I reboot or otherwise make an ovn node unavailable. I have only tried with a specific one. All my instances that have DNS names via all my network zones disappear.No amount of rebooting or restarting lxd snap deamon gets it to come back .

The way I got this back the last time was as a trouble shooting step, I tried to downgrade my cluster to 5.13 and that didn’t take. I re-installed 5.14 and that… I don’t know did something to bring it back.

I looked at the LXD Log and it gives nothing other than a couple of heart beat failures and the cluster attempting to contact each other every time I tried to restart the lxd daemon on the cluster nodes.

Is there anywhere else I should be looking. It has been working pretty solid with out any issues up until I came to 5.14


Please can you clarify what you mean by “network zones” and “disappear”?

Are you using VMs btw?

Hey @tomp!

Sure! I mean the lxd network zone feature that lxd has when instances spin up they get a dns name in which I transfer out to another DNS server.

By disappear I mean, when I do a dig on the zone ( got the command from lxd documentation) I see none of the instance DNS names in the zone, which were previously there as well all my monitoring started failing.

I am using vms!!

This only started occuring, as far as I paid attention, when a ovn control VM that I have was having network issues. I also happened to update a couple of weeks before. Don’t know if that’s coincidence or correlation.

Just to add more context I hope… OVN looks health, the cluster looks intact, LXD cluster looks intact. Nothing is screaming something is broken other than the dns records not being where they are supposed to be.

I also just tested creating a new lxd instance and it does get a DNS name created in the zone just fine. However, when I added a static ip address to the instance , the dns name disappared from the zone. I think that’s by design… When I removed the static address, the instance would not get another dns name. It would seem that once it’s gone, it’s gone.


1 Like

Hey @tomp any ideas? I’m really looking for just a way to try to troubleshoot and have something meaningful to look for help :slight_smile:

Thank you

Hi sorry for the delay on this, are you able to log an issue over at with the reproducer steps we can try? Thanks

I just noticed someone else has asked about this already.
I have posted a Github issue that explains this.

Yea I just tried removing and restarting and got the same bug you have. I have moved away from forward zones because of it’s instability… It’s a great future once they get it down.