Problems importing VMs

I’ve been trying to import a Windows 11 developer VM image. Microsoft offers different versions, such as the VMware, VBox, etc. I grabbed the VBox image, unpacked it and used the import tool that you guys mention on your documentation. After creating a token and all that, i get an rsync error immediately and it just dies.

After that, I spent a while trying to force that image to be imported as a disk image. I converted it to a raw image with qemu and then tried to DD it over the block device, but that was apparently causing errors on boot as something probably didn’t copy over correctly.

Would love it if there were one of the following options:

  1. Ability to import as a first-class command in incus. i.e.: incus import
  2. Ability to import a raw disk directly from incus. i.e.: incus storage volume import -t disk

Tangential, but how are you guys mounting the zvol? It’s not showing up as a volume until i start the VM, then it shows up as a zvol. Perhaps being able to directly mount that without the system running would allow me to force in the disk image.

zfs set volmode=full pool/path/to/dataset.block

You’d want incus-migrate for importing the raw disk image, though the fact that it’s using rsync in your case makes it sound like you were running it in container mode somehow?

Though a few things to note:

  • incus-migrate requires a raw disk image, so you need to convert the vmdk to a raw disk image first
  • Those developer images aren’t likely to have the needed virtio storage drivers, so they’ll most likely just fail to boot with an error saying the disk couldn’t be found. You may give io.bus=nvme a try which may get you past this.

ah good to know on the zfs command.

I got incus-migrate to work the second time around, must have selected container the first time like you mentioned. That said, i ran into the same issue. i added the tmp and stuff too, and basically it starts with the bios logo and the little spinning wheel on the bottom. then it just hangs before it gets to anything windows. there unfortunately are no logs that i can find so it’s not clear why it hangs.

I tried all three block device types, including nvme and they all had the same hang issue. any other ideas?

The windows images are here: