Remote error - trying to move container


(pieter) #1

I run

lxc move ngs galaxy:

and get:

error: Failed container creation:

  • https://172.19.32.32:8443: Error transferring container data: exit status 23
  • https://10.105.69.1:8443: Error transferring container data: Unable to connect to: 10.105.69.1:8443
  • https://[fd42:5046:95f3:83f8::1]:8443: Error transferring container data: Unable to connect to: [fd42:5046:95f3:83f8::1]:8443

galaxy has been setup as remote, and it worked previously, as I already moved snapshots to galaxy.
Servers are pingable…
any help debugging?


Problem with Live Migration
(Stéphane Graber) #2

You may want to take a look at lxd.log on both source and destination servers, the exit status 23 sounds like rsync being unhappy.


(Stéphane Graber) #3

Error 23 for rsync is partial transfer due to error. Hopefully the error in question made it to the log of the source or target servers.


(pieter) #4

Hi,
Should have checked the logs.

In the early design stages I stored quiet a bit of data in the container, and snapshotted that. It filled my disk in no time. Even up tot the point new snapshot entries were taken, but the disk was already full.
As some of the snapshots were like created in the /var/snap/lxd/common/lxd folder but were not show in lxc info, I just deleted the snapshot folders.
And that is were is got a problem.
Lxc list now showed a certain snapshot, but the folder directory was no longer there, and therefor the whole thing crashed.
I now deleted the snapshot using lxd delete xx/xx and everything worked fine…

@stgraber Thanks for the really fast replies, and the awesome software stuff! have learned quiet a bit lately!