Samba and acl on ext4

Hi everyone,

I am currently trying to set up a samba server container on an ext4 filesystem and I’d like to use ACLs inside the container.
I am trying to build this inside a qnap container station with lxc 2.0.6. As far as I can tell it is a privileged container, since the data in /var/lib/lxc belongs to root and I see the processes inside the container on the outside with the same uids.
I’ve played with rootfs.options = acl=1 and separate bind mounts with the acl mount options. But everytime when I run mount in the Ubuntu 20 container I see the noacl remark for the file systems and can’t setfacl on any file I want to put into the smb share.
If anymore is required I’ll gladly post.
All hints are very welcome, since I struggle with finding out details about the rootfs backend directory and what rootfs.options are available.
The uids (root=0) are the ones that count for this, afaik and those are 0 on both host and guest.
And yes i am a lxc noob :slight_smile:


To share my findings:
I realized the acls were also disabled on the host system and therefore weren’t available inside the container. To check I used ssh to get into the host and ran mount there. I saw the main RAID was mounted with noacl.
Enabling the advanced folder permissions in the share folder settings made acls available inside the container.