Samba in LXD container & Windows ACLs

I have created a mamber server running samba 4.10.6 to an Active Directory domain in a LXD container. I have set Windows ACLs on the share in accordance with ethe samba WiKi and they work fine. However if I restart the container, when trying to access the share I get Access Denied errors. Have tried several things, but re-applying the ACLs to the shared folder (even though they still look the same as before) restores access.

It seems that some setting is not being maintained between restarts, but I have no idea where to look. Any help will be appreciated.

I am running Debian Buster on the host and the container. lxd is version 3.14



Apologies for replying to my own post, but further research showed this type of problem occurs when a filing system is created on the complete disk eg mkfs.ext4 /dev/sdb and using that as a device added to the container. Changing that to a normal partition table with fdisk then creating the filing system on the partition eg /dev/sdb1 and using that instead solved the problem.

I hope that helps others who face this issue.