Some VMs crash at Boot

hi, some VMs, with os’s like Windows Server 2012 or Centos 7 will crash at boot with the following error:

qemu-system-x86_64: Issue while setting TUNSETSTEERINGEBPF: Invalid argument with fd: 44, prog_fd: -1

by crash i mean freeze,

for windows 2012 this only happens when i enable “hyper v enlightenments”
i am using a simple macvlan in the profile
Ubuntu,alpine,debian will boot just fine
lxd 5.18

architecture: x86_64
  raw.qemu: -cpu host,+pcid,+spec-ctrl,+stibp,+ssbd,+pdpe1gb,+md-clear,+kvm_pv_eoi,+kvm_pv_unhalt,+lahf_lm,+sep,hv_ipi,hv_relaxed,hv_reset,hv_runtime,hv_spinlocks=0x1fff,hv_stimer,hv_synic,hv_time,hv_vapic,hv_vpindex,hv-vendor-id=NV43FIX
    -machine q35,hpet=off,accel=kvm
  security.secureboot: "false"
  volatile.base_image: 5beca5dba80ad1a44efd0009ed6cd6fb9fe67f9c7abdea888e7e7a74ee549d03 5e88ad7b-cda4-400b-a202-c0d2fe4d9099
  volatile.eth0.host_name: mac7ec76289
  volatile.eth0.hwaddr: 00:16:3e:b9:42:1f
  volatile.eth0.last_state.created: "false"
  volatile.last_state.power: RUNNING
  volatile.last_state.ready: "false"
  volatile.uuid: db8b4a6d-185c-4906-9e4c-37be5c33cbf1
  volatile.uuid.generation: db8b4a6d-185c-4906-9e4c-37be5c33cbf1
  volatile.vsock_id: "829391745"
    source: /home/user/master/data/VMISOs/vm/iso/config-2.iso
    type: disk
ephemeral: false
- p3vm
stateful: false
description: ""```

Solved the boot issue by removing “hv_stimer” flag, but something is wrong with NIC in vm , nic wont take ipv4 , and the error still exist, i should mention lxd in nested and i tried "virtio"and “e1000e” nic type on host, any idea how to fix it?