Start armv7 container on arm64 with lxc / lxd

I try my luck here, as I got no answer on stack exchange:

I installed Ubuntu 20.04 on my Raspberry PI, which has an arm64v8 architecture (but could be on any other debian arm distribution / hardware).

Currently I compile a program for several arm architectures / distros. So I use lxc container for that purpose. This worked well for all debian and ubuntu versions for the arm64v8 architecture.

Then I downloaded an armhf container for debian buster, which technically should be architecture arm32v7 alias armv7:

lxc launch images:debian/10/armhf armhf-buster

Then I logged in the container and uname -a says: armv8l. I tried even to compile, but pip wheel refuses to take the arm32v7 packages and therefore I have to compile all dependencies for arm32v8 myself, which takes ages (waited 4 hours for one package and then aborted) due to limited memory and cpu capacaties.

Anyways: is there a way to launch a container as armv7 on an arm64v8 distro?

P.s.: also obviously I can install the official Raspberry PI OS, which is armv7l on that armv8 processor, so technically shouldn’t be a problem to run that as lxc virtualization.