System does not fully support snapd: cannot mount squashfs image using

I am trying to install LXD on Redhat, however I think the first time it worked, but then I when i tried to install the ZFS support it mucked it up, then I have reinstalled redhat over and over again , tried instructions and can’t get it work. I have installed squashfs-tools, I keep getting the following error:

[jimbo@redhat ~]$ sudo snap install lxd
error: system does not fully support snapd: cannot mount squashfs image using "squashfs": mount:
       /tmp/sanity-mountpoint-897093557: unknown filesystem type 'squashfs'.

So if I run modprobe

[jimbo@redhat ~]$ sudo modprobe squashfs
modprobe: FATAL: Module squashfs not found in directory /lib/modules/4.18.0-147.8.1.el8_1.x86_64

Then I have tried

[jimbo@redhat ~]$ sudo dnf install kernel-modules
Updating Subscription Management repositories.
Last metadata expiration check: 0:21:25 ago on Mon 15 Jun 2020 20:59:28 CEST.
Package kernel-modules-4.18.0-193.el8.x86_64 is already installed.
Package kernel-modules-4.18.0-193.6.3.el8_2.x86_64 is already installed.
Dependencies resolved.
Nothing to do.

I think the issue is caused because I am installing zfs support.

Hmm, yeah, your kernel definitely needs to have squashfs support. But that’s a very common function so something must be quite wrong with your kernel modules…

What does find /lib/modules | grep squashfs find?

I already started to reinstall redhat again, but it will pop up again. One thing I noticed, is that I am on redhat 8.2, and the ZFS releases only go upto 8.1, is it possible that this is causing the issue?

sudo yum install

In the meantime, I will follow same instructions but without ZFS and see if that still causes the issue.

I have just reinstalled redhat, and before touching it, i ran the command

[root@redhat ~]# find /lib/modules | grep squashfs

These are the only commands which do something to the kernel, so it must be one of these.

sudo grubby --args="user_namespace.enable=1" --update-kernel="$(grubby --default-kernel)"


sudo yum install

Sorry for digging up this post again, but I get the same error on Debian bullseye, I set the loop module as lxc config set <container_name> linux.kernel_modules loop and install fuse package in container and everything runs smoothly.