"The stop hook failed" + Deletion fails


Since a bit, stopping containers fails, I think it has to do with the new LXD versions, since it worked before. Currently I am using LXD 4.0.x stable on a few Ubuntu 20.04 servers.

All what I get is this:

location: none
container: machina
err: ‘Failed to deactivate LVM logical volume “/dev/primary/containers_machina”: Failed to run: lvchange --activate n --ignoreactivationskip /dev/primary/containers_machina: Logical volume primary/containers_machina contains a filesystem in use.’
level: eror
message: The stop hook failed
timestamp: “2020-08-15T14:15:03.037474884+02:00”
type: logging

I do not understand why this is happening, all worked fine before.
The container has nothing running on it, nothing that could block that.

Any ideas?

It also appears to happen with deletion of a container.

A restart seems to fix it… interesting.
Question is, what was the cause or is it likely to happen again?

Anyone got an idea? it repeats itself over and over again.
It does also affect multiple nodes independently.

Try grep containers_machina /proc/*/mountinfo that may locate any process which still has this thing mounted, preventing the deletion.