Ubuntu containers not getting ipv4 adresses


Hi all, new to this forum so forgive me if it’s in the wrong place.

I recently upgraded my systemd version from 247 to 248, and now when I start the lxd service, my Ubuntu containers (trusty and xenial) are unreachable over my lxdbr0 interface. It turns out they are not getting an ipv4 address, but they do have an ipv6 address. Some other containers on Debian buster are still accessible though and working fine.
I tried a couple of thing but I’m not getting far (still consider myself quite a noob with Linux). Only things I found out is that I can force the containers to get an ipv4 address by using lxc shell to get into the containers and then ifup eth0. However, this still doesn’t allow me to ssh to the container for instance. I’ve tried to find out some information by running journalctl or systemctl, but it give me these outputs:

root@db-simple:~# journalctl
No journal files were found.
– No entries –
root@db-simple:~# systemctl
Failed to connect to bus: No such file or directory

I then tried to run /etc/init.d/dbus start, and after that I got this message:

root@db-simple:~# systemctl status
Failed to read server status: Input/output error

It does seem to be related to the systemd upgrade, because when I rolled back to 247, it worked fine again.
Like I said, I consider myself quite a noob stil, only using Arch and lxc/lxd for about 5 years now, so it feels like I’m quite stuck, and really hoping you guys can help me out here :slight_smile:

I am not sure, but this could also be related to the problem described here:

Basically systemd switched to cgroup v2 and the normal method under Arch is not compatible to that.
So you can either switch to cgroup v1, which is described in the wiki or see
this: Pam_cgfs How to setup with cgroup v2? for using cgroup v2.

Thanks, forcing systemd to use cgroup v1 with kernel parameters worked!
Still wondering why this wasn’t an issue for my debian containers.