Unable to access image server

Hi ,
I have lxd daemon running on one host, with few public images.
I am trying to download an image from this server from another host on same LAN.
I am getting the following error ??
command : lxc-create -t download -n mycont – --server xx.xx.xx.xx:8443
Downloading the image index
ERROR: Failed to download http://xxx.xx.xx.xx:8443//meta/1.0/index-system


You’re missing old style LXC and LXD here. You can’t use the lxc-download template against a LXD server.

Thanks for the reply, How to import and image into LXC 2.1.1?
I tried the following with exported tar balls out of LXD and tried to import i n LXC.
lxc-create -t local -n some-name tarfile metafile
lxc-create -t local -n some-name -f tarfile -m metafile
I dont have local template installed, could not find one how to get/install?
I also tried with -t alpine because all my images alipine based. None worked
Thanks in advance for any inputs.

We’re not going to provide support on 2.1.1, it’s an unsupported release.

That release predates distrobuilder and the current images, so it can’t consume them out of the box.

Your best bet is to manually unpack things into place and manually write config.

Thanks again, would like to get info on one thing:
I created an alpine container in lxc2.1.1, using below
lxc-create -t download -n myalpine …
(1) How I can export this container in LXC 2.1.1 ?
(2) How I can import this container in LXC 2.1.1 back ?
Best Regards.