Unable to create OVN peering


I followed the guide related to install cluster with ovn networking (https://linuxcontainers.org/incus/docs/main/howto/network_ovn_setup/)

Now, when I want to create peering between ovn interfaces it shows the following issue:

# incus network peer create ovn2 ovn1-to-ovn2 ovn1
Error: Failed creating peer: sql: no rows in result set

I use stable release on a cluster install and also tested with daily release on another cluster install with same result.


That’s odd, can you show incus network list?

I am getting the same error.

incus network peer create test1-ovn test1-to-test test-ovn
Error: Failed creating peer: sql: no rows in result set

I’ve reproduced the issue, looking into it now.

I’ll push the fix to my stable package once we have it reviewed and merged.

Ok waiting for it; shall we compile from github code?

It should be in the stable package within the next 24h so hopefully you don’t need to start building Incus locally.

Ok, noted. I am also trying to update using the sql subcommand of ‘incus admin’; tried some insert but the change is not fully applied (It is showed on the peer list , however , I cannot ping between the ovn’s)

Fix has been merged and stable is rebuilding with it now.

1 Like

Ok this solved the problem its working fine now.