VM agent always fails to boot

I was experimenting with Incus and I am not able to incus shell to any VM instance.

incus console myvm --show-log always shows a [FAILED] Failed to start incus-agent.service - Incus - agent..

I’ve tried with images:debian/12 and images:debian/13. On incus/try-it it just works, so there’s something wrong with my system.

I’ve tried disabling secure boot, to no avail. Containers work just fine. What else can I try to debug this?

Using incus 6.0.4 on Ubuntu 25.10 installed with apt.

Hmm, I’m not super familiar with the Ubuntu/Debian native package, though since you’re not on Ubuntu LTS, that’s basically your only option :slight_smile:

Most likely what’s going on is a bad agent binary for some reason.
Check that you have the incus-agent package installed as I believe that’s required with those packages, then run file against the incus-agent binary to make sure it’s a static binary, if it’s somehow dynamically linked, then it definitely won’t work.

@gibmat may have more ideas since those should be the same packages he built in Debian.

For some reason it appears that the incus-agent binary isn’t being copied into the VM’s config directory. Within a VM, the incus-agent.service log includes

(us-agent)[350]: incus-agent.service: Unable to locate executable '/run/incus_agent/incus-agent': No such file or directory

From the host system, manually running

sudo cp /usr/libexec/incus/incus-agent /var/lib/incus/virtual-machines/<VM>/config/

and restarting the VM gets things working again.

Not sure what’s going wrong; trixie shipped with the same version of Incus, and incus-agent works fine.

It was exactly that @gibmat , thank you!

Glad that the workaround helped you!

I’m still going to see if I can figure out why it’s not working on Ubuntu. However, someone on the Ubuntu side would then need to pull the fix into Ubuntu’s packaging.

For reference, using the LTS Zabbly packages (currently at 6.0.5) fixes the issue. It wasn’t trivial to install them on Ubuntu 25.10, I had to download libfuse3-3 from 24.04.