Vm can not start

Hi all.

The vm failed to start for the following reasons.
Please help to solve the problem.

root@ubuntu:/# lxd --version

Error: Failed to run: forklimits limit=memlock:unlimited:unlimited – /snap/lxd/20987/bin/qemu-system-x86_64 -S -name c01 -uuid 429cf0e8-4037-4616-ae65-173914916c88 -daemonize -cpu host -nographic -serial chardev:console -nodefaults -no-user-config -sandbox on,obsolete=deny,elevateprivileges=allow,spawn=deny,resourcecontrol=deny -readconfig /var/snap/lxd/common/lxd/logs/c01/qemu.conf -spice unix=on,disable-ticketing=on,addr=/var/snap/lxd/common/lxd/logs/c01/qemu.spice -pidfile /var/snap/lxd/common/lxd/logs/c01/qemu.pid -D /var/snap/lxd/common/lxd/logs/c01/qemu.log -smbios type=2,manufacturer=Canonical Ltd.,product=LXD -runas lxd: char device redirected to /dev/pts/0 (label console)
: Process exited with non-zero value 1
Try lxc info --show-log c01 for more info

root@ubuntu:/# lxc info --show-log c01
Name: c01
Location: none
Remote: unix://
Architecture: x86_64
Created: 2021/07/15 07:08 UTC
Status: Stopped
Type: virtual-machine
Profiles: default


qemu-system-x86_64: error: failed to set MSR 0x48f to 0x7fffff00036dfb
qemu-system-x86_64: …/target/i386/kvm.c:2701: kvm_buf_set_msrs: Assertion `ret == cpu->kvm_msr_buf->nmsrs’ failed.

Thank you very much.

Hmm, that’s a pretty bad crash from qemu.
What kernel, distribution and hardware platform is this being run on?


The configuration environment is as follows.

Lenovo Thinkpad P15s – windows 10 – vmware workstation16 – ubuntu 21.04 – LXD

Thank you very much.

So that’s the issue. You’re trying to do nested virtualization and it looks like QEMU isn’t happy about it.

It could be the CPU not supporting it or it may be VMWare not allowing it.
I’d recommend doing some googling around nested virtualization in vmware to see if there are some configuration to tweak to allow it.

Thank you very much . @stgraber.

Nested Virtualization can set up vmware workstation as follows.

  1. H/W Option in VM

  2. Add the following 3 lines to the vm configuration file(.wmx).
    hypervisor.cpuid.v0 = “FALSE”
    mce.enable = “TRUE”
    vhv.enable = “TRUE”

Thank you very much. ^^