VM not booting from Windows ISO

Did anything change for us to create a VM?

lxc init win10 --empty --vm -c security.secureboot=false -c limits.cpu=8 -c limits.memory=8GB
lxc config device override win10 root size=250GB
lxc config device add win10 iso disk source=/home/vitorafgoomes/ISOs/Win/win10-distrobuilder.iso boot.priority=10

Looks like it didn’t find the EFI boot partition on the iso for some reason?
You can reboot again and during the countdown (3s), press ESC to go in the firmware and try to force it to boot, but it looks like there may be something wrong with the ISO?

What LXD version is that?

I tried putting the boot as the first two but it returned the same error.


Split it to a separate topic to avoid posting too many responses to the tutorial post.

Can you maybe try booting EFI Internal Shell in the boot menu?
This should get you a DOS-like shell with a bunch of drives attached to it.

When it launches it should show a list of drives, the ones to look for are the FS ones like FS0. For each of those, you can then try something like:


Which would list what the firmware sees in the drive.

That would be correct.

ok, can you do:

cd efi

what’s in boot?

Windows 10 Enterprise

Could it be the Windows version to return this error?

I will try to create another image.

no, I meant:

cd boot

To see what’s in that boot directory.

As far as images, we usually just use the .iso that you can directly download from Microsoft. It’s a unified ISO with all the WIn10 variants.

ok, I’m downloading the one from the website.

Correct, just download the one you said worked.

Thanks for your help and your attention.


There definitely seem to be a bunch of odd Windows ISOs out there which don’t work at all like the ones Microsoft provides on their website these days…