Why does Lxc list not display IPv4 network

lxd version 4.0.4
os: vitual-machine
1、lxc network create bridge
2、lxc config device add instance sss nic type=nic nictype=bridged parent=bridge
3、lxc console instance
4、ip a can view the IP address
5、lxc list don‘t show ipv4

Please show output of ip a on the LXD host and the output of ps aux | grep dnsmasq?

Physical host

LXD host

Please show sudo ss -ulpn

I suspect you have libvirt’s dnsmasq preventing LXD’s one from starting.

Yeah you have dnsmasq listening on that will prevent LXD’s one from starting.
You need to update it to only listen on the addresses/interfaces it needs.

Yes, is libvert used because of the impact of this service, so that the IP is not obtained?

I’m not sure what is running dnsmasq on your system it may be libvirt though.

ok, thanks. I’ll turn off libvert and have a look

turning off libvirt still doesn’t work. Do I need to do anything else?

And did it fix the dnsmasq listener?

the current dnsmasq listener is not listening for libvert

Please show sudo ss -ulpn and ps aux | grep dnsmasq

this is the display of the physical host

I don’t know what’s listening here, but it’s not libvert dnsmasq

You didnt provide the ss output.

Yes looks like you still have another wildcard listener instance of dnsmasq running.

the whole cluster network is monitored here. shutting down will affect the ssh service, so maybe not

when ssh is used to enter the virtual machine, the ip can be displayed

I’m talking about dnsmasq not ssh.

do you mean that dnsmasq will affect the service itself? I’m sure the libvert service is not being monitored at present. Will dnsmasq itself affect it, or do I need to turn it off