WiFi card passed to LXD container results in failure to start

I am encountering an issue attaching a device to a container.
launched a container, shut down the container, attached a wireless card
Steps taken:

  • Launched humane-leach
  • Installed prerequisite packages in container
  • Shutdown container
  • Attached wireless card with the command:
    $ lxc config device add humane-leach wlp1s0 nic nictype=physical parent=wlp1s0 name=wlp1s0
  • Attempted to start container; received error
  • Changed security.privileged to true as a troubleshooting step
  • Attempted to start the container, received same error

Would like advice on troubleshooting the issue. This procedure has worked on 2 other intel+bionic devices.


  • Ubuntu Bionic
  • LXD 3.0 installed via apt (not snap)
  • All steps taken as root account



lxc 20180523014854.749 ERROR    lxc_network - network.c:lxc_network_move_created_netdev_priv:2472 Failed to move network device "wlp1s0" to network namespace 17775: Operation not permitted
lxc 20180523014854.749 ERROR    lxc_start - start.c:lxc_spawn:1678 - Failed to create the configured network
lxc 20180523014854.809 ERROR    lxc_container - lxccontainer.c:wait_on_daemonized_start:824 - Received container state "ABORTING" instead of "RUNNING"
lxc 20180523014854.810 ERROR    lxc_start - start.c:__lxc_start:1866 - Failed to spawn container "humane-leech"
lxc 20180523014854.816 WARN     lxc_commands - commands.c:lxc_cmd_rsp_recv:130 - Connection reset by peer - Failed to receive response for command "get_cgroup"


Does setting parent= and name= to the target of /sys/class/net/wlp1s0/phy80211 somehow work better? In my case here, that’d be phy4.

If so, that’s because of the split between the hardware wireless card and the logical interface created on top of it. You can’t move just one logical interface but instead need to move the entire card.

1 Like

I will try that when I have my hands on the device next.