Windows Server 2022 clean shutdown


I have a Windows Server 2022 guest machine installed. As far as I can see, if tell Incus to stop the guest, it does nothing.

What is required to get it working?


Windows is kinda funny in that it often takes more than one ACPI event to shut it down.

Try running the incus stop command again within a second or so of the first attempt and it should actually start the shutdown process.

I’ll see if we can’t have Incus always send the ACPI shutdown even twice, hopefully that doesn’t cause issues on Linux systems.

As far as I can see, it worked.

I think this is not the way to go. I would recommend a windows parameter/setting for the specific Windows VM. We can provide it during or after VM creation. Based on this send the ACPI twice.