Discuss.linuxcontainers.org seems to be down a lot

Not sure if a meta discussion of the forum is appropriate here, but I too frequently find that when I’m trying to get to this page, it doesn’t resolve, with the appearance of the server being down. Is this just my imagination? I haven’t made any effort to document this and am not on this forum all the time, but anecdotally 2-3 times a month the link won’t resolve.

Echo this, its incredibly slow to load most of the time :smile:

Not seeing an obvious problem here, so we’ll need more details to investigate.

Thanks, Stéphane. Next time I can’t connect I’ll jot down the date/time and will append to this post. It was definitely in the last 7 days that I noticed I got a response from Tom, tried to go to the forum, and couldn’t connect.

@stgraber just to chip in here, I also see this frequently (last night it was happening).
I think its possibly not showing up in the monitoring because rather than refusing TCP/HTTP connections, when I try and view the forum, it seems to not respond (no error is given, it just hangs).

My gut feeling is that its hanging on a long running DB query perhaps. Perhaps only if a user is logged in (which may also explain why the monitoring doesn’t detect it).

It seems worse during the evening (UK time) and is generally responsive during my working day.

So, maybe it is just super slow to load. I just tried accessing the forum (2023-05-25 7:30pm CST) and it took a couple of minutes for the page to load.

That’s really weird because I was actively loading pages on it at the same time…
Here a full forced refresh of this page takes 923ms to load. It may be interesting to see what it gets hold up on if you can use the developer mode in your web browser to look at it.

This time after Shift-reload the page opened instantly. Let me try closing the page and clicking on the email link again.

Yep, now it loads instantly. Maybe Tom is right and it’s some kind of database thing.

It just happened again. I tried switching to another topic I’m working on and got this message:

Sorry, we couldn’t load that topic, possibly due to a connection problem. Please try again. If the problem persists, let us know.

Clicking on Try Again a couple of time resulted in the same message. The third time the topic page loaded after a brief delay.

I don’t think this is a networking issue on my end as other people seem to be having similar issues.

Hitting the developer view in your browser (F12 in firefox) to look both at the Console and Network tabs would be pretty helpful.

On the server side, I’ve been keeping an eye for the past few hours and fixed a couple of DB errors (missing extension) and one deprecated config key but otherwise, load has been extremely low, no slow requests recorded, no slow DB queries recorded and CPU load at 0.05. So whatever it is feels network related, just need to figure out when accessing what exactly and what’s the error.


I also often have this problem of slow response from the site, not only when first connecting but when retrieving other topics. I also get an interesting error occasionally when typing a reply (if I take too long?) that it will tell me that the message is being edited elsewhere. This sounds like a load balancing problem perhaps, where you’re losing the session and it re-establishes it against another back end?

Edit : I had an episode of very slow loading just now. I couldn’t see anything specific in F12 except a few NS_BINDING_ABORTED errors which seem to potentially mean a lot of different things, several of them not important. Just now I got my draft is being edited in another window, this seems to be from an insecure (?!) connection to POST discuss.linuxcontainers.org drafts.json and that’s getting an NS_ERROR_NET_TIMEOUT.

Edit 2 : and this in console, which relates to the editing the post in another window and complains with a 409 error (“Conflict”).

Today super slow. It hangs on establishing the TLS handshake, according to Firefox, before timing out and giving me an error page.

I wonder @stgraber - did you say that linuxcontainers.org is now served from the UK as well? I’m in the UK and I wonder if it is related to an issue in the local instance here.

Its the /poll endpoint that takes a while to respond for me, the page often loads its waiting for that response that takes the time.

If you look at the response it contains deatils on what is and isn’t read, speculatively as your account gets older and the forum gets busier its these “calcs” that cost the time. Subsequent loads are fast so I assume it gets cached.

“naming things & cache invalidation” strikes again

I’m just surprised that LXD seems to be treated as an arm’s length project that runs on its own infra, as opposed to part of the Canonical mothership and therefore residing on the corporate platform?

It’s incredibly confusing anyway - MAAS is at maas.io but is branded Canonical MAAS, Landscape is at landscape.canonical.com (for the SaaS service) but branded Ubuntu Landscape at ubuntu.com/landscape for self-hosted, and then we have LXD which is branded Linux Containers (?) at linuxcontainers.org and not branded either Canonical or Ubuntu, but linked on Canoncial.com by something that says ubuntu.com/lxd but points at the Linux Containers site. So, bascially, what?

Its half owned by Oracle I think, or Oracle had a hand in creating it.

I think its the same reason the web-ui is under cannoical and LXD is “out on its own”.

I to have found the “please provide image servers” requests … odd, but that doesn’t contribute much to this issue of the slow forum :smile:

Almost tempted to spend the $1,144 to buy lxd.io and see what happens. :rofl:

You find out how poor you are compared to the Oracles lawyers :wink: :joy:

Well it’s owned by a domain squatter at the moment so if Oracle hasn’t rung their bell yet …

And ubuntu.io was squatted (presumably) by someone in Poland in 2019.

Just took me three attempts to get the comment submitted. :frowning: