I can no longer access lxd

I have been using lxd on my development machine, now it is no longer working!

$ lxc ls

I got the below response:

Error: Get "http://unix.socket/1.0": dial unix /var/snap/lxd/common/lxd/unix.socket: connect: connection refused

I checked, if anything has changed, but I am still in lxd groud:

$ groups
olutayo adm cdrom sudo dip plugdev lpadmin sambashare libvirt lxd
$ whoami

I also check with id:

$ id
uid=1000(olutayo) gid=1000(olutayo) groups=1000(olutayo),4(adm),24(cdrom),27(sudo),30(dip),46(plugdev),116(lpadmin),126(sambashare),130(libvirt),999(lxd)

I do not know, what is wrong?

I just did a fresh install of LXD, and ran sudo lxd init

you might not have a problem but… I have never used lxc ls so… unsure what output you’d expect here

try lxc list or lxc launch ?

lxd --version


I tried to launch and I can only be these defaults… utilize LXC when using sudo

I have been using it consistently of sometime, but, now stopped working!

lxd --version


lxc list
Error: Get "http://unix.socket/1.0": dial unix /var/snap/lxd/common/lxd/unix.socket: connect: connection refused

Hi @solutayo,
Can you post the output of the sudo systemctl status snap.lxd.daemon and sudo journalctl -u snap.lxd.daemon -n 20

1 Like

Hi @cemzafer ,

Thank you for help, it is pointing out the problem; lxd daemon not starting, probably as a result of " Failed to run: modprobe -b zfs"

sudo systemctl status snap.lxd.daemon

sudo journalctl -u snap.lxd.daemon -n 20

Looks like you have a storage pool using ZFS but are now running a kernel which lacks ZFS support.

1 Like

This is strange to me, about two years ago, I accepted ZFS , which was the default storage, specified with lxd init, and it has been working until now! Maybe the system updates of over the period tampered with the it, as I never interacted with it directly!

What is the way out?

@solutayo, I suppose that executing modprobe zfs will solve the problem.

1 Like

Thank you @cemzafer , I did but, it is like the module is not in the kernel



It seems you use a mainline 5.15 kernel, this one doesn’t embed specific patchs or drivers addition from Canonical applied to Ubuntu. Since ZFS is embed in the regular Ubuntu kernel (LTS or HWE) and not from the mainline kernel, you can’t load the ZFS module because it’s not there. You can try an HWE kernel such as the latest 5.13 and it should work.

1 Like

I only apply update, when it is available, I did not interact or do anything with the kernel directly !

Can you try with that command, sudo apt install zfs-dkms.

1 Like

I did that, but it did not bring solution

Have you checked your zfs module with lsmod or did you execute modprobe zfs, you can even search zfs.ko module? What was zfs-dkms command return, error or without error.

1 Like

That’s bother me because I thought the latest kernel available on Ubuntu 20.04 should be the 5.13 one through “Hardware Enablement” aka HWE (except if you install a mainline kernel).

uname -a return a 5.15 kernel right ?

apt list --installed | grep linux could be interesting as well to see kernel packages installed.

$ lsmod | grep -i zfs              ### returns nothing


$ zfs-dkms
zfs-dkms: command not found
$ uname -a
Linux orixmach 5.15.8-76051508-generic #202112141040~1639505278~20.04~0ede46a~dev-Ubuntu SMP Fri Dec 17 x86_64 x86_64 x86_64 GNU/Linux


$ apt list --installed | grep linux

Is your computer a System76 machine by any chance ? Looks like you have a third-party repository enabled which provides you a “PopOS” kernel. The linux-system76 package seems to indicate this (looks like a package which provides a repository/PPA). Moreover your kernel seems to be tagged as dev, I’m 100% sure this is not a native Ubuntu kernel.

1 Like

@solutayo, can you post the more /etc/os-release command output? I thought you were using Ubuntu.