Lxd ceph cluster connection error


How do I solve this problem?

ceph : nautilus, centos 7.8
client: ubuntu 20.04

I tried referring to the URL below, but it failed.

Error message is below

Thank you

I got it working as follows, you have do a few tweaks and then change the line for mon servers in ceph.conf to the old way without the brackets etc.

snap set lxd ceph.builtin=true
mkdir /var/snap/lxd/common/ceph
systemctl reload snap.lxd.daemon

copy the relavent files to new location
 cp /etc/ceph/ceph.conf  /var/snap/lxd/common/ceph
 cp /etc/ceph/ceph.client.admin.keyring /var/snap/lxd/common/ceph
## change mon host line to be like this:
mon host =,,,
no square brackets etc.

Create pools and stuff

on ceph mon node

rbd pool init lxd1
reboot the snap daemon for lxd
 systemctl reload snap.lxd.daemon

lxd create storage

lxc storage create ceph3 ceph source=lxd1
lxc storage set ceph3 volume.size 500GB

Thank you @bodleytunes

First, below the picture.

I did what you said and it worked.

The ceph storage was tested in two versions.
case 01 --> ubuntu 18.04, nautilus, ceph-ansible
case 02 --> centos 7.8, nautilus, ceph-ansible
client --> ubuntu 20.04

In the first case, it worked fine without changing the ceph.conf file or the lxd value.

In the second case, it wasn’t in the default state, and as you told me to modify and create the ceph storage, it worked.

Thanks again for telling me how.

Well, it’s a ceph composed of ansible, if I need to run ansible again, then ceph.conf seems to go back to its original state.

평안한 밤 되세요. ^^

1 Like